const regex = /[^\n{]*(?<![.@#])\bimg\s*{[^}]*\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\n{]*(?<![.@#])\\bimg\\s*{[^}]*\\}', 'g')
const str = `thead
{
/*some code*/
}
tr,img {
/*some code*/
}
@page {
img{
}
}
p,h2,h3 {
/*some code*/
}
h2,h3 {
/*some code*/
}
img {
/*some code*/
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}