re = /[^\n{]*(?<![.@#])\bimg\s*{[^}]*\}/
str = 'thead
{
/*some code*/
}
tr,img {
/*some code*/
}
@page {
img{
}
}
p,h2,h3 {
/*some code*/
}
h2,h3 {
/*some code*/
}
img {
/*some code*/
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end