$re = '/[^\n{]*(?<![.@#])\bimg\s*{[^}]*\}/';
$str = 'thead
{
/*some code*/
}
tr,img {
/*some code*/
}
@page {
img{
}
}
p,h2,h3 {
/*some code*/
}
h2,h3 {
/*some code*/
}
img {
/*some code*/
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);