import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\((?P<imp>[A-Z])\\)\\ )?(?P<dued>(?:2[0-1][0-9]{2}\\-(?:0[0-9]|1[0-2])\\-(?:[0-2][0-9]|3[0-1]))|\\?)\\ (?:\\+(?P<proname>[a-zA-Z0-9]+)(?:\\#(?P<pronum>[0-9]+))?\\ )?(?:\\$(?P<startd>2[0-1][0-9]{2}\\-(?:0[0-9]|1[0-2])\\-(?:[0-2][0-9]|3[0-1]))(?:\\^(?P<repeat>\\d*(?:D|W|M|Y)(?:\\,\\d*(?:D|W|M|Y)+)*))?\\ )?(?P<todo>.+?(?=(?:\\ (?:\\@|\\&))|$))(?P<contexts>(?:\\ \\@\\S+)*)(?P<tags>(?:\\ \\&\\S+)*)";
final String string = "(A) 2016-10-23 +projectB $2016-10-03 to be completed as soon as possible @context_bar\n"
+ "(A) 2016-11-01 +projectA $2016-09-25 job to complete @context @context_two\n"
+ "(B) ? +houseworks $2016-10-04^2D,W lavoro importante &TAG_FOO &TAG_BAR\n"
+ "2016-12-15 +projectA#2 $2016-09-25 second job related to the same project @another_context\n"
+ "? +houseworks $2016-10-02^3D altro lavoro di casa @context_bar &TAG\n"
+ "? +projectA#3 $2016-09-25 third job of the same project @foo_context &WAIT\n"
+ "? +projectA#4 $2016-09-25 fourth job, needs third to be completed first\n"
+ "2016-11-23 $2015-06-23^4Y another job without project @context_foo @context_bar &TAG_A &TAG_B\n"
+ "? minimal job like email fra@me.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}