using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:a|(?<!^)\G)[^abc\n]*)c(?=[^ab\n]*b)";
string substitution = @"\1x";
string input = @"cuacducucibclaccb
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}