re = /((?:a|(?<!^)\G)[^abc\n]*)c(?=[^ab\n]*b)/
str = 'cuacducucibclaccb
'
subst = '\\1x'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result