$re = '/((?:a|(?<!^)\G)[^abc\n]*)c(?=[^ab\n]*b)/';
$str = 'cuacducucibclaccb
';
$subst = "\1x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;