import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^-]*-[^-]*\\K.*$";
final String string = "60166213\n\n"
+ "60173866-4533\n\n"
+ "60167323-9439-1259801\n\n"
+ "NL170-2683-1262201\n\n"
+ "60174710-1-A12-4";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}