const regex = /^[^-]*-[^-]*\K.*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^-]*-[^-]*\\K.*$', 'gim')
const str = `60166213
60173866-4533
60167323-9439-1259801
NL170-2683-1262201
60174710-1-A12-4`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);