$re = '/^[^-]*-[^-]*\K.*$/im';
$str = '60166213
60173866-4533
60167323-9439-1259801
NL170-2683-1262201
60174710-1-A12-4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;