const regex = /\b(?>['\w-]+\W+){0,4}dolore magna(?:\W+['\w-]+){0,4}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?>[\'\\w-]+\\W+){0,4}dolore magna(?:\\W+[\'\\w-]+){0,4}', 'gi')
const str = `Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed.`;
const subst = `<b>$0</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);