$re = '/\b(?>[\'\w-]+\W+){0,4}dolore magna(?:\W+[\'\w-]+){0,4}/i';
$str = 'Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed.';
$subst = "<b>$0</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;