re = /\b(?>['\w-]+\W+){0,4}dolore magna(?:\W+['\w-]+){0,4}/i
str = 'Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed.'
subst = '<b>$0</b>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result