import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!rolf$).+$";
final String string = "roooolf\n"
+ "r123olf\n"
+ "123rolf123\n"
+ "rolf5623\n"
+ "123rolf\n"
+ "rollllf\n"
+ "rrrrrrolf\n"
+ "rolffff\n"
+ "rolf\n"
+ "rol\n"
+ "rolf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}