import re
regex = re.compile(r"^(?!rolf$).+$", flags=re.MULTILINE)
test_str = ("roooolf\n"
"r123olf\n"
"123rolf123\n"
"rolf5623\n"
"123rolf\n"
"rollllf\n"
"rrrrrrolf\n"
"rolffff\n"
"rolf\n"
"rol\n"
"rolf")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")