re = /^(?!rolf$).+$/m
str = 'roooolf
r123olf
123rolf123
rolf5623
123rolf
rollllf
rrrrrrolf
rolffff
rolf
rol
rolf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end