using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^([0-9a-fA-F]{2})+$)|((?:[0-9a-fA-F]{2}([:]))+(?:[0-9a-fA-F]{2})*([0-9a-fA-F]{2})+$)";
string input = @"0
00
000
0000
00000
000000
aa:bb:cc:dd:ee:ff:00
AA:BB:CC:DD:EE:FF
0:
00:
00:0
00:00
00:00:
00:00:0
00:00:00
00:00:00:
00:00:00:00:00:00:00:00:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}