// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^([0-9a-fA-F]{2})+$)|((?:[0-9a-fA-F]{2}([:]))+(?:[0-9a-fA-F]{2})*([0-9a-fA-F]{2})+$)").unwrap();
let string = "0
00
000
0000
00000
000000
aa:bb:cc:dd:ee:ff:00
AA:BB:CC:DD:EE:FF
0:
00:
00:0
00:00
00:00:
00:00:0
00:00:00
00:00:00:
00:00:00:00:00:00:00:00:00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}