import re
regex = re.compile(r"(^([0-9a-fA-F]{2})+$)|((?:[0-9a-fA-F]{2}([:]))+(?:[0-9a-fA-F]{2})*([0-9a-fA-F]{2})+$)", flags=re.MULTILINE)
test_str = ("0\n"
"00\n"
"000\n"
"0000\n"
"00000\n"
"000000\n\n"
"aa:bb:cc:dd:ee:ff:00\n"
"AA:BB:CC:DD:EE:FF\n\n"
"0:\n"
"00:\n"
"00:0\n"
"00:00\n"
"00:00:\n"
"00:00:0\n"
"00:00:00\n"
"00:00:00:\n"
"00:00:00:00:00:00:00:00:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")