#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d)(?=(\d{3})+\b)"
Local $sString = "1" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"1000" & @CRLF & _
"10000" & @CRLF & _
"100000" & @CRLF & _
"1000000" & @CRLF & _
"10000000" & @CRLF & _
"100000000" & @CRLF & _
"1000000000" & @CRLF & _
"10000000000" & @CRLF & _
"100000000000" & @CRLF & _
""
Local $sSubst = "$1,"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)