import re
regex = re.compile(r"(\d)(?=(\d{3})+\b)")
test_str = ("1\n"
"10\n"
"100\n"
"1000\n"
"10000\n"
"100000\n"
"1000000\n"
"10000000\n"
"100000000\n"
"1000000000\n"
"10000000000\n"
"100000000000\n")
subst = "$1,"
result = regex.sub(subst, test_str)
if result:
print(result)