use strict;
my $str = 'Word1-A-OK
Word2-Sample-R-OK
Word3-A';
my $regex = qr/(\w+)-(?:[AR](?:-(?:NG|OK))?|[WC])$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";