$re = '/(\w+)-(?:[AR](?:-(?:NG|OK))?|[WC])$/m';
$str = 'Word1-A-OK
Word2-Sample-R-OK
Word3-A';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;