# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!(e\d|\\n))[a-z]//gm;t' <<< "azjf8ee7Ldoge \n Hmeqze= AZ12D Fs \nsdfz14eZe148r "