re = /(?!(e\d|\\n))[a-z]/m
str = 'azjf8ee7Ldoge \\n Hmeqze= AZ12D Fs \\nsdfz14eZe148r '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result