import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"(.*?)\\\".*>Launch";
final String string = "<a class=\"wcmListViewLink\" target=\"_blank\" href=\"getContent?objectStoreName=Nice&vsId=%7BE6B85994-9B93-4A3C-878A-C7BBBA39BAD8%7D&objectType=document&folderId=%7BB51627F8-D74C-4607-ADD7-AC9C125D67F9%7D\" class=\"btn\">Launch Information Processing Workflow</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}