const regex = /href="(.*?)\".*>Launch/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="(.*?)\\".*>Launch', '')
const str = `<a class="wcmListViewLink" target="_blank" href="getContent?objectStoreName=Nice&vsId=%7BE6B85994-9B93-4A3C-878A-C7BBBA39BAD8%7D&objectType=document&folderId=%7BB51627F8-D74C-4607-ADD7-AC9C125D67F9%7D" class="btn">Launch Information Processing Workflow</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}