#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([fx]*?)"
Local $sString = "xfooxxxxxxfoo" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)