const regex = /([fx]*?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([fx]*?)', 'g')
const str = `xfooxxxxxxfoo
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);