use strict;
my $str = 'xfooxxxxxxfoo
';
my $regex = qr/([fx]*?)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";