const regex = /(?<=\s)#\w+(?!.*[@$#])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)#\\w+(?!.*[@$#])', 'gm')
const str = `1. While #EngineSpeed\$b4tgup#
2. While #AcceleratorPedal\$desddd# <=2
3. While #AcceleratorPeda@\$desddd# <=2
4. While #AcceleratorPe#al\$desddd# <=2
5. While #AcceleratorP@dal\$desddd# <=2
6. While #AcceleratorPeda l\$desddd# <=2
7. 设置 #AcceleratorPedal\$y6qs8m#=@AcceleratorPedal+0.06
8. 设置 #WaitStart\$jhx0vu#=11
9. 设置 #WaitStart\$jhx0vu#^11
10. 设置 #WaitStart\$jhx0vu#_11
11. 设置 #WaitStart\$jhx0vu#-11
12. 设置 #AcceleratorQuora\$yd6ba3#=1
13. 设置 #AcceleratorQuora\$yd6bd3#=1
14.
15. Check #EnginePower#
16. While #EngineSpeed
17. set #WaitStart
18. set #WaitStart<13
19. set #WaitStart<=13
20. set #WaitStart <= 13`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}