# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\s)#\w+(?!.*[@$#])"
test_str = ("1. While #EngineSpeed$b4tgup#\n"
"2. While #AcceleratorPedal$desddd# <=2\n"
"3. While #AcceleratorPeda@$desddd# <=2\n"
"4. While #AcceleratorPe#al$desddd# <=2\n"
"5. While #AcceleratorP@dal$desddd# <=2\n"
"6. While #AcceleratorPeda l$desddd# <=2\n"
"7. 设置 #AcceleratorPedal$y6qs8m#=@AcceleratorPedal+0.06\n"
"8. 设置 #WaitStart$jhx0vu#=11\n"
"9. 设置 #WaitStart$jhx0vu#^11\n"
"10. 设置 #WaitStart$jhx0vu#_11\n"
"11. 设置 #WaitStart$jhx0vu#-11\n"
"12. 设置 #AcceleratorQuora$yd6ba3#=1\n"
"13. 设置 #AcceleratorQuora$yd6bd3#=1\n"
"14.\n"
"15. Check #EnginePower#\n"
"16. While #EngineSpeed\n"
"17. set #WaitStart\n"
"18. set #WaitStart<13\n"
"19. set #WaitStart<=13\n"
"20. set #WaitStart <= 13")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.