using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*?(<img.*?>)<\/a>";
string input = @"<a href=""something.html"" alt=""blah""><img src=""image1.jpg"" alt=""image 1""></a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}