re = /<a.*?(<img.*?>)<\/a>/
str = '<a href="something.html" alt="blah"><img src="image1.jpg" alt="image 1"></a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end