$re = '/<a.*?(<img.*?>)<\/a>/';
$str = '<a href="something.html" alt="blah"><img src="image1.jpg" alt="image 1"></a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);