package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\?P<([a-zA-Z]+)>(([a-zA-Z0-9-_+*:?|\[\]!<>^(),\.\\]+)|(?R)?)\)`)
var str = `/^\/test\/(?P<token>p(ae)rn)\.(?P<format>h(((t)))))))ml)\/$/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}