// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\?P<([a-zA-Z]+)>(([a-zA-Z0-9-_+*:?|\[\]!<>^(),\.\\]+)|(?R)?)\)").unwrap();
let string = "/^\\/test\\/(?P<token>p(ae)rn)\\.(?P<format>h(((t)))))))ml)\\/$/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}