#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^[a-z0-9](?!.*?[^\na-z0-9]{2}).*?[a-z0-9]$"
Local $sString = "877sswere" & @CRLF & _
"@877sswere" & @CRLF & _
"!877sswere^" & @CRLF & _
"877sswere$" & @CRLF & _
"8&*77sswere" & @CRLF & _
"87#7ssw$er^e" & @CRLF & _
"877^sswere"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")