using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9](?!.*?[^\na-z0-9]{2}).*?[a-z0-9]$";
string input = @"877sswere
@877sswere
!877sswere^
877sswere$
8&*77sswere
87#7ssw$er^e
877^sswere";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}