$re = '/^[a-z0-9](?!.*?[^\na-z0-9]{2}).*?[a-z0-9]$/im';
$str = '877sswere
@877sswere
!877sswere^
877sswere$
8&*77sswere
87#7ssw$er^e
877^sswere';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);