using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-(?<flag>[a-zA-Z]) (?<value>.+?)(?=$| -[a-zA-Z])";
string input = @"-a 1 -b -5.1 -c Hello World -d Something Else";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}