$re = '/-(?<flag>[a-zA-Z]) (?<value>.+?)(?=$| -[a-zA-Z])/m';
$str = '-a 1 -b -5.1 -c Hello World -d Something Else';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);