re = /-(?<flag>[a-zA-Z]) (?<value>.+?)(?=$| -[a-zA-Z])/m
str = '-a 1 -b -5.1 -c Hello World -d Something Else'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end