use strict;
my $str = '[[wiki page|display text]]
[[wiki page]]
';
my $regex = qr/((?<=\[\[)[^|]*|(?<=\|).*?)(?=\]\])/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";