re = /((?<=\[\[)[^|]*|(?<=\|).*?)(?=\]\])/
str = '[[wiki page|display text]]
[[wiki page]]
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result