$re = '/((?<=\[\[)[^|]*|(?<=\|).*?)(?=\]\])/';
$str = '[[wiki page|display text]]
[[wiki page]]
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;