using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,\s]*\b""\b[^,\s]*|""[^""]*""|[^,\s]+";
string input = @"""Super Bus"" dri""ver bus1, dri""ver1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}