$re = '/[^,\s]*\b"\b[^,\s]*|"[^"]*"|[^,\s]+/m';
$str = '"Super Bus" dri"ver bus1, dri"ver1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);