#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<(p|h3)[^>]*>\s*?(<a .*?><img.*?><\/a>|<img.*?>)?\s*<\/\1>"
Local $sString = "<p><a ><img></a></p>" & @CRLF & _
"<h3><a ><img></a></h3>" & @CRLF & _
"<p><a ><img></a></p>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")