using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(p|h3)[^>]*>\s*?(<a .*?><img.*?><\/a>|<img.*?>)?\s*<\/\1>";
string input = @"<p><a ><img></a></p>
<h3><a ><img></a></h3>
<p><a ><img></a></p>
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}